Una ayudita para reparar mi ZX-Gomas de 48k

Sinclair QL, ZX81, +2, +3, 128K ...
Avatar de Usuario
Mirloblan
Dragon 32
Dragon 32
Mensajes: 18
Registrado: 02 Ago 2015, 23:21
Sistema Favorito: Spectrum 16Kb/48Kb
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Ubicación: Barcelona
Contactar:

Una ayudita para reparar mi ZX-Gomas de 48k

Mensajepor Mirloblan » 17 Sep 2015, 23:26

Muy buenas a tod@s,

Compré un Gomas bien de precio a pesar de saber que estaba averiado, con la esperanza de poder arreglarlo.

El pequeño gomas arranca con un borde blanco normal, pero en la parte central aparecen barras rojas y negras verticales que se mueven hacia un lado o se alternasen.

Procedí a leer voltajes y me encontré con tensiones de +5 -5 y 12v más o menos dentro de lo normal: 5v -4,7v i 13,2v
Luego hice la prueba de la memoria alta, es decir, la bloqueé para que sólo fuese la baja cruzando las patillas de un IC que ví en internet, es un Issue3b. Y nada hacía lo mismo.
Después le cambié el Z80A y aproveché para ponerle un zócalo y NADA, sigue igual.
Como ví que había dos IC's de memoria alta con zócalo, compré un par de memorias y las cambié, y NADA.

Ahora ya no se que hacer, en principio la avería no es la ULA, o eso me ha parecido leer, ya que si fuese ULA rota no se vería correctamente el borde, y está OK.

El que me lo vendió me dijo que la avería era debida a sacar una interface "en caliente", vamos con el Gomas encendido.

La verdad es que es una pena porque el teclado y la apariencia externa es OK, está de p... madre, a las malas lo dejo de "exposición".

Gracias de antemano a los que me ayuden,

Saludos,

Mirlo

Avatar de Usuario
mcleod_ideafix
Amiga 2500
Amiga 2500
Mensajes: 5316
Registrado: 06 Oct 2009, 04:12
Sistema Favorito: Spectrum 16Kb/48Kb
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Vectrex
Primera consola: TV Games/Pong Clone
Ubicación: Jerez de la Frontera
Gracias dadas: 12 veces
Gracias recibidas: 51 veces
Contactar:

Re: Una ayudita para reparar mi ZX-Gomas de 48k

Mensajepor mcleod_ideafix » 18 Sep 2015, 00:49

Mirloblan escribió:Procedí a leer voltajes y me encontré con tensiones de +5 -5 y 12v más o menos dentro de lo normal: 5v -4,7v i 13,2v
Luego hice la prueba de la memoria alta, es decir, la bloqueé para que sólo fuese la baja cruzando las patillas de un IC que ví en internet, es un Issue3b. Y nada hacía lo mismo.
Después le cambié el Z80A y aproveché para ponerle un zócalo y NADA, sigue igual.
Como ví que había dos IC's de memoria alta con zócalo, compré un par de memorias y las cambié, y NADA.

Has hecho todo lo que se puede hacer, excepto una cosa, que es de las primeras que tendrías que haber hecho: comprobar que la memoria baja funciona, que va a ser que no.

Mirloblan escribió:Ahora ya no se que hacer, en principio la avería no es la ULA, o eso me ha parecido leer, ya que si fuese ULA rota no se vería correctamente el borde, y está OK.

Una ULA rota se manifiesta de muchas formas, no únicamente por el estado del borde.

Mirloblan escribió:El que me lo vendió me dijo que la avería era debida a sacar una interface "en caliente", vamos con el Gomas encendido.

Eso significa que la pista de 5V y la de 9V podrían haberse tocado por un momento, y eso es fuente de cantidad de problemas. Si ha pasado eso, cualquiera de los chips, o todos (menos quizás el LM1889) pueden haberse estropeado. De todas formas, ya que se ve que tienes maña para quitar chips y ponerlos en zócalos, haz eso con los 8 chips de la memoria baja y busca algún recambio, por ejemplo con memorias 4164, o con una plaquita que venden en SellMyRetro y que sustituye las 8 memorias bajas por una pequeña memoria SRAM, mucho más fiable que las memorias 4116 originales.
Recuerda: cada vez que se implementa un sistema clásico en FPGA, Dios mata a un purista

Avatar de Usuario
Mirloblan
Dragon 32
Dragon 32
Mensajes: 18
Registrado: 02 Ago 2015, 23:21
Sistema Favorito: Spectrum 16Kb/48Kb
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Ubicación: Barcelona
Contactar:

Re: Una ayudita para reparar mi ZX-Gomas de 48k

Mensajepor Mirloblan » 18 Sep 2015, 17:32

WOW McLeod-Ideafix se nota que dominas!!!

Muchas gracias hombre, me parece buena idea lo de cambiar toda la memoria por esa de la plaquita que comentas.

El que se le dan bien los zócalos es mi amigo Ramón, yo soy un patata con el soldador.

Voy a darle una vuelta al asunto a ver, al final me saldrá casi igual que comprarlo nuevo jajaja

Un abrazo,

Mirloblan

tranx
Commodore 128
Commodore 128
Mensajes: 111
Registrado: 11 Jun 2015, 20:44
Sistema Favorito: PC
primer_sistema: MSX
consola_favorita: (Otro)
Primera consola: Sony PlayStation 1
Gracias recibidas: 10 veces

Re: Una ayudita para reparar mi ZX-Gomas de 48k

Mensajepor tranx » 21 Sep 2015, 17:02

Animo, a ver si se puede dar vida a ese gomas

Avatar de Usuario
Mirloblan
Dragon 32
Dragon 32
Mensajes: 18
Registrado: 02 Ago 2015, 23:21
Sistema Favorito: Spectrum 16Kb/48Kb
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Ubicación: Barcelona
Contactar:

Re: Una ayudita para reparar mi ZX-Gomas de 48k

Mensajepor Mirloblan » 18 Oct 2015, 22:27

Tras muchas pruebas creo que he encontrado la avería señores, el tercer módulo DRAM de memoria baja estaba jodido.

Con mi destreza con el soldador he sacado el chip, me he cargado una pista (que he podido arreglar), pero ahora no tengo huevos a montarla, se lo voy a pasar a un amigo a ver :D

Os voy informando

Gracias por todo

Mirlo


Volver a “Sinclair/Spectrum”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 4 invitados